一、文档被取消
1.排除下打印机是否有问题,可以先打印一个word文档看下能不能正常打印。
2.如果打印机能正常打印,可以重装下打印控件再打印
二、打印渲染失败:
如果是下面这个提示:
解决方法:
一般是驱动有问题或内存不足导致的。
1,注意检查电脑C盘,看下是不是C盘满了,清理一下内存!
2,在电脑左下角运行 cmd ,然后执行 sfc /scannow
执行之后,如果显示下图中的信息,那么说明电脑系统损坏了,需要重装下电脑系统,或者是换个电脑安装软件。
也可以先查看打印组件日志,查下是否有如下关键字:
CreateDC failed Begin painter failed
如果发现上述关键字,通常是打印机驱动存在问题
删除打印机驱动,如果删除失败,尝试重启后删除;
安装打印机驱动,安装完打印机驱动,需要重启电脑;
三、打开日志目录的方法:
电脑右下角双击打印控件图标,然后点击 帮助--打开日志目录,然后选择需要的日期的日志。(文档不能直接发送的话,可以复制到桌面再发送)
四、 打印有偏移:
解决方法
请去打印预览与设置里面,设置打印偏移
五、打印不完整,有空边:
解决方法
1. 可以点击控件界面上的 强制设置页面无空边
解决方法
1. 可以点击控件界面上的 强制设置页面无空边
2.有的用户的打印机设置了 边距,或者有的打印机默认设置了边距,也会导致偏移,如下图;如果打印机设置了边距,请把边距设置为0.
3.如果还不行,可以把页面缩放下,然后去系统的打印与预览设置界面里设置下偏移
六、预览不完整:
解决方法
去模板设计器里选下打印机并保存
七、模板文件格式不符合规范或者数据不符合规范:
解决方法:
1)先去菜鸟控件主界面点击:工具--清除缓存 ,再重新打印下。如果不行要下菜鸟日志,让技术看下
2)纸张大小跟实际纸张大小是否一致
八、提示下载失败:
解决方法
重启下路由器,不行参考下面的:
https://support-cnkuaidi.taobao.com/support/hotProblemDetail.htm?spm=a21da.7386797.0.0.CMk27a&source=search&id=296585
九、打印正在处理,打印等待
解决方法
1.看下纸张高度设置,是不是太小了。(一般小于50的都注意下)太小的话,需要设置的大一点
2.有可能是模板纸张高宽设置的不对(比如本来应该是210*150,却设置成了21*15),请将纸张高宽改成正确的。改完后需要在任务管理器里将控件结束任务再重新打开
十、获取的电子面单号无分拣信息,无路由信息,集包地信息,大头笔信息,这是为什么?
解决方法
电子面单系统在生成面单时,可能会对分拣信息计算系统超时,这个会导致生产的面单没有任何分拣信息。
分拣信息同时也存在完全计算不出的情况,虽然概率比较小,但是会发生,也属于正常的情况。 快递公司不能拒收这样的件。
遇到这样的情况,建议取消面单,再取一次,或者换一家快递公司再取一次。
十一、水印打印过黑问题
解决方法
https://open.taobao.com/doc.htm?docId=107810&docType=1
十二、条码不是太长就是太短?
这个涉及到条码的生成原理,条码长度是不能任意调整的,他的长度是由最小黑条决定的,最小黑条由1变成2,整体长度就会变长很多
要么就减少条码位数,要么加大纸张。
十三、菜鸟推荐打印机
https://www.cainiao.com/markets/cnwww/leakproof
十四、控件连接失败的问题
处理方法:
1.首先检查控件是否有安装,如果安装了有没有开启,如果没开启则启动下控件
2.排除下浏览器是否有问题(UC浏览器有问题),推荐谷歌,360,搜狗,QQ。火狐和ie11需要加白名单
3.看下系统里有没有360,安全管家,防火墙之类的软件,有的话关闭掉再重新打下看看。
4.如果还不行,可以去控制面板-防火墙里,把防火墙关闭再打印
十五、提示无效打印的问题
解决方法
1)打印预览和设置页面,核实选择的打印机的名称和电脑的控制面单的打印机名称是否是一样
2)打印预览和设置页面,选择其他的打印机保存之后,重新选择指定的打印机保存打印操作
3)桌面运行的控件关闭重新启动运行 登录系统操作一下
4)卸载打印控件重新安装
十六、设置默认打印机
十七、菜鸟打印控件安装了,打印预览还是提示要安装
解决方法
1.浏览器极速兼容模式切换一下,换浏览器试试
2.右下角看下控件是否在正常运行
3.菜鸟控件主界面能不能正常打开。如果不能按以下步骤操作下:
* 问题原因
建行网银或工行网银后台服务没有启动时影响了Windows系统导入其 他程序的证书。
* 解决方案
第一步:“程序”→“控制面板”→“管理工具”→“服务”,或者在开始菜单直接运行services.msc
第二步:依次选择建行“HDZB Comm Service for V2.0”和工行“ICBC Daemon Service”的系统服务程序,点击左侧的“启动此服务”;
第三步,在任务管理器结束CNPrintClient进程,重新双击“CaiNiao打印组件”图标启动。
4.卸载重装控件,重启电脑。
十八、正在处理,请稍后,一直在加载任务
如上图所示,如果用户直接打印碰到这种情况,首先确认以下几点:
1.打印的是什么单子
2.用的是什么浏览器
目前我们系统对打印的逻辑支持是普通单子需要用兼容模式打印,电子面单需要用极速模式,如果符合这个规律还是不能打单,让用户打开打印预览与设置,打开设计模板,等设计模板加载完毕,再点击打印预览,打印预览ok了,接下来就可以直接打单了;造成这个的原因是,电脑关机后,打印控件的加载信息就会清空,需要重新加载一次;
十九、下载失败
A:快递单,配货单都可以正常打印,发货单不能打印会报错。
Q:图片链接过期,删掉重新上传
十八、Q:发货单模板设计里面自定义的文本不能跟着明细一起变动,容易被覆盖
A:自定义文本设置下边距固定,右边勾选下边距固定项紧贴商品明细就可以了
十九、抖音电子面单打印提示报错:faild: TaskID redefined
处理方案:重启下抖音组件即可